package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:font-family:|https?:\/\/)[^\s\'";}]*(*SKIP)(*FAIL)(media)`)
var str = `#mediator .media
amedias media lorem ipsumedia ar
{ el : "https://twitter.com/intent/medias/" } Amedia
.element{ font-family: media} .media`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}