import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:font-family:|https?:\\/\\/)[^\\s\\'\";\\}]*(*SKIP)(*FAIL)(media)";
final String string = "#mediator .media\n"
+ "amedias media lorem ipsumedia ar\n"
+ "{ el : \"https://twitter.com/intent/medias/\" } Amedia\n"
+ ".element{ font-family: media} .media";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}