package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\b\w)|(.)`)
var str = `alan dos santos silva`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}