import re
regex = re.compile(r"(\b\w)|(.)")
test_str = "alan dos santos silva"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)