import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "s:\\d+:\"themes\";s:\\d+:\"[\\w,\\s]*(\\bbusinessman\\b)[\\w,\\s]*\";";
final String string = "a:4:{s:5:\"dates\";a:2:{s:7:\"created\";s:27:\"2017-11-03T01:14:56.582259Z\";s:8:\"imported\";s:27:\"2017-11-03T01:14:56.582259Z\";}s:11:\"displayName\";s:12:\"Donald Trump\";s:11:\"description\";s:17:\"Donald John Trump\";s:6:\"themes\";s:10:\"apple, Businessman, Politician\";}";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}