// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)s:\d+:"themes";s:\d+:"[\w,\s]*(\bbusinessman\b)[\w,\s]*";"#).unwrap();
let string = "a:4:{s:5:\"dates\";a:2:{s:7:\"created\";s:27:\"2017-11-03T01:14:56.582259Z\";s:8:\"imported\";s:27:\"2017-11-03T01:14:56.582259Z\";}s:11:\"displayName\";s:12:\"Donald Trump\";s:11:\"description\";s:17:\"Donald John Trump\";s:6:\"themes\";s:10:\"apple, Businessman, Politician\";}";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}