$re = '/news\/[a-z0-9_-]+\/[0-9]+$/m';
$str = 'news/news_url
news/page/30';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);