using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*%(?!([.]?[0-9]+)?[a-zA-Z]).*$";
string input = @"dsfdf (%) dsfgs %d s32523
%d %d % %t dsg
sfsf %d
dfsd %.464d, %353T";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}