re = /^.*%(?!([.]?[0-9]+)?[a-zA-Z]).*$/m
str = 'dsfdf (%) dsfgs %d s32523
%d %d % %t dsg
sfsf %d
dfsd %.464d, %353T'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end