re = /^\!\s*(R|r)edirect:/m
str = '! Redirect: Tells the adblocker to look for list updates from a new URL from that point on. To be used in the old file only (Not the new one), to avoid an infitite redirection loop
redirect:not()
redirect:has(
##redirect:
#?#redirect:
##moz-redirect:
redirect:contains(
! Redirect:
! redirect:
!Redirect:
!redirect:
! Redirect:
! redirect:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end