import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Владелец: (\\w+_\\w+)";
final String string = "style=\"top:813.166px;left:830.066px;background:url(/images/business_0.gif)\" title=\"<div class='text-center'>Амуниция/Тир<br><br>Владелец: Richard_Universe</div>\" data-toggle=\"tooltip\" data-html=\"true\"></div><div class=\"map-icon business-state-0 business-not-sale\" style=\"top:558.291px;left:1013.365px;background:url(/images/business_0.gif)\" title=\"<div class='text-center'>Амуниция/Тир<br><br>Владелец: Brake_Blame</div>\" data-toggle=\"tooltip\" data-html=\"true\"></div><div class=\"map-icon business-state-0 business-not-sale\" style=\"top:603.893px;left:616.15px;background:url(/images/business_0.gif)\" title=\"<div class='text-center'>Амуниция/Тир<br><br>Владелец: Queens_Nakamura</div>\" data-toggle=\"tooltip\" data-html=\"true\"></div><div class=\"map-icon business-state-1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}