use strict;
my $str = '"When I went to school, they asked me what I wanted to be when I grew up. I wrote down "Happy." They told me I didn\'t understand the assignment, and I told them they didn\'t understand every life."
';
my $regex = qr/((\W+?)?)((\w+?)?)(([aeiou|AEIOU]+?)?)(\w+?)(\W+?)/mxp;
my $subst = '\\7\\4ay ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";