# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
((\W+?)?)((\w+?)?)(([aeiou|AEIOU]+?)?)(\w+?)(\W+?)
"""
test_str = ("\"When I went to school, they asked me what I wanted to be when I grew up. I wrote down \"Happy.\" They told me I didn't understand the assignment, and I told them they didn't understand every life.\"\n")
subst = "\\7\\4ay "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.