$re = '/(?<=,)[^,]*$/m';
$str = 'Log First Meal Time,Twitter,Midday Routines Done,Midday Routines';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);