#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d+px"
Local $sString = "{"background":"linear-gradient(225deg,rgba(255, 255, 255, 0.36) 0%,rgba(255, 255, 255, 0.8) 100%)","boxShadow":"0 12px 12px -3px rgba(0, 0, 0, 0.08),0 -8px 14px 0 rgba(255, 255, 255, 0.76),inset 0 0 1px 0 rgba(255, 255, 255, 1),inset 0 2px 0 0 rgba(255, 255, 255, 1)"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")