#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)SummerTLE"
Local $sString = "{" & @CRLF & _
" "id": "1"," & @CRLF & _
" "method": "store"," & @CRLF & _
" "params": {" & @CRLF & _
" "model": "Impression"," & @CRLF & _
" "objects": [" & @CRLF & _
" {" & @CRLF & _
" "campaignName": "HTML Summer PAID"," & @CRLF & _
" "campaignTypeImpressionNumber": 3," & @CRLF & _
" "campaignTypeSessionImpressionNumber": 1," & @CRLF & _
" "eventName": "mainLto3"," & @CRLF & _
" "eventNumber": 1," & @CRLF & _
" "impressionNumber": 1," & @CRLF & _
" "inAppStatus": "paying"," & @CRLF & _
" "isDefaultConfig": false," & @CRLF & _
" "maxLevel": 0," & @CRLF & _
" "mode": "default"," & @CRLF & _
" "parameters": {" & @CRLF & _
" "tleName": "summertle"" & @CRLF & _
" }," & @CRLF & _
" "sessionEventNumber": 1," & @CRLF & _
" "sessionImpressionNumber": 1," & @CRLF & _
" "sessionNumber": 2," & @CRLF & _
" "subscriptionStatus": "free"," & @CRLF & _
" "timestamp": 1659778581.808" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "campaignName": "Nested: Paid Offer 1"," & @CRLF & _
" "campaignTypeImpressionNumber": 3," & @CRLF & _
" "campaignTypeSessionImpressionNumber": 1," & @CRLF & _
" "eventName": "mainLto3"," & @CRLF & _
" "eventNumber": 1," & @CRLF & _
" "impressionNumber": 1," & @CRLF & _
" "inAppStatus": "paying"," & @CRLF & _
" "isDefaultConfig": false," & @CRLF & _
" "maxLevel": 0," & @CRLF & _
" "mode": "default"," & @CRLF & _
" "parameters": {" & @CRLF & _
" "tleName": "summertle"" & @CRLF & _
" }," & @CRLF & _
" "sessionEventNumber": 1," & @CRLF & _
" "sessionImpressionNumber": 1," & @CRLF & _
" "sessionNumber": 2," & @CRLF & _
" "subscriptionStatus": "free"," & @CRLF & _
" "timestamp": 1659778581.809" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "campaignName": "Nested: Paid Offer 2"," & @CRLF & _
" "campaignTypeImpressionNumber": 3," & @CRLF & _
" "campaignTypeSessionImpressionNumber": 1," & @CRLF & _
" "eventName": "mainLto3"," & @CRLF & _
" "eventNumber": 1," & @CRLF & _
" "impressionNumber": 1," & @CRLF & _
" "inAppStatus": "paying"," & @CRLF & _
" "isDefaultConfig": false," & @CRLF & _
" "maxLevel": 0," & @CRLF & _
" "mode": "default"," & @CRLF & _
" "parameters": {" & @CRLF & _
" "tleName": "summertle"" & @CRLF & _
" }," & @CRLF & _
" "sessionEventNumber": 1," & @CRLF & _
" "sessionImpressionNumber": 1," & @CRLF & _
" "sessionNumber": 2," & @CRLF & _
" "subscriptionStatus": "free"," & @CRLF & _
" "timestamp": 1659778581.809" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "campaignName": "Nested: Paid Offer 3"," & @CRLF & _
" "campaignTypeImpressionNumber": 3," & @CRLF & _
" "campaignTypeSessionImpressionNumber": 1," & @CRLF & _
" "eventName": "mainLto3"," & @CRLF & _
" "eventNumber": 1," & @CRLF & _
" "impressionNumber": 1," & @CRLF & _
" "inAppStatus": "paying"," & @CRLF & _
" "isDefaultConfig": false," & @CRLF & _
" "maxLevel": 0," & @CRLF & _
" "mode": "default"," & @CRLF & _
" "parameters": {" & @CRLF & _
" "tleName": "summertle"" & @CRLF & _
" }," & @CRLF & _
" "sessionEventNumber": 1," & @CRLF & _
" "sessionImpressionNumber": 1," & @CRLF & _
" "sessionNumber": 2," & @CRLF & _
" "subscriptionStatus": "free"," & @CRLF & _
" "timestamp": 1659778581.81" & @CRLF & _
" }" & @CRLF & _
" ]" & @CRLF & _
" }," & @CRLF & _
" "jsonrpc": "2.0"" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")