import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:[A-Za-z][A-Za-z0-9.-]*@(?:aig\\.com|abc\\.in|abc\\.uk))(?:,(?!$)|$))*$";
final String string = "abc@aig.com\n"
+ "abc@aig.com,xyz@abc.uk\n"
+ "abc@aig.com,\n"
+ "abc@aig.com,xyz@abc.uk,\n"
+ "xyz@aig.com,@xyz@abc.in,xyz@abc.uk\n"
+ "xyz@aig.com,xyz@abc.in,xyz@abc.uk\n"
+ "xyz@aig.com,xyz@abc.in,xyz@abc.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}