using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Metodo di pagamento).*\n\x07.*";
string substitution = @"\0#end";
string input = @"Metodo di pagamento selezionato:
Mastercard
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}