using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http[s]?:\/\/)[^\/]+\/(.*?)\?";
string input = @"http://www.vkontakte.ru/lenitskyofficial
https://www.vkontakte.ru/lenitskyofficial
http://www.vk.com/lenitskyofficial
https://www.vk.com/lenitskyoffici_3al
https://www.vk.com/lenitskyofficial?qw=w123qwe";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}