import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http[s]?:\\/\\/)[^\\/]+\\/(.*?)\\?";
final String string = "http://www.vkontakte.ru/lenitskyofficial\n"
+ "https://www.vkontakte.ru/lenitskyofficial\n"
+ "http://www.vk.com/lenitskyofficial\n"
+ "https://www.vk.com/lenitskyoffici_3al\n"
+ "https://www.vk.com/lenitskyofficial?qw=w123qwe";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}