using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#(\w+)\s";
string input = @"john#456 18 mai 2017 11:01";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}