use strict;
my $str = '0.000000
-0.00000
+0.0000
.1
+.1
-.1
+00000.1
-00000.1
000000000000000.1
000.1111
00.11
0.1
-0.1
+0.1
1.1
+1.1
-1.1
10.11
+10.11
+10.11
100.11
+100.11
-100.11
1000.111
+1000.111
-1000.111';
my $regex = qr/^[-+]?([1-9]*[0-9]?\.|0\.)?[0-9]+([eE][-+]?[0-9]+)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}