#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{5}(-\d{4})?"
Local $sString = "12345-1000" & @CRLF & _
"12345" & @CRLF & _
"123451231" & @CRLF & _
"12345-123" & @CRLF & _
"12345adfe" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"12345" & @CRLF & _
"12345-1234" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")