package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{5}(-\d{4})?`)
var str = `12345-1000
12345
123451231
12345-123
12345adfe
12345
12345-1234
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}