#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "{[^}]*"updated_at":"(?!2020-10-12)[^"]*"}"
Local $sString = "[{"id":"1","status":"0","created_at":"2020-10-12 12:00:00","updated_at":"2020-10-12 12:00:00"},{"id":"2","status":"1","created_at":"2020-10-13 12:00:00","updated_at":"2020-10-13 12:00:00"}," & @CRLF & _
"{"id":"3","status":"2","created_at":"2020-10-14 12:00:00","updated_at":"2020-10-14 12:00:00"}]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")