using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{[^}]*""updated_at"":""(?!2020-10-12)[^""]*""}";
string input = @"[{""id"":""1"",""status"":""0"",""created_at"":""2020-10-12 12:00:00"",""updated_at"":""2020-10-12 12:00:00""},{""id"":""2"",""status"":""1"",""created_at"":""2020-10-13 12:00:00"",""updated_at"":""2020-10-13 12:00:00""},
{""id"":""3"",""status"":""2"",""created_at"":""2020-10-14 12:00:00"",""updated_at"":""2020-10-14 12:00:00""}]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}