use strict;
my $str = '[{"id":"1","status":"0","created_at":"2020-10-12 12:00:00","updated_at":"2020-10-12 12:00:00"},{"id":"2","status":"1","created_at":"2020-10-13 12:00:00","updated_at":"2020-10-13 12:00:00"},
{"id":"3","status":"2","created_at":"2020-10-14 12:00:00","updated_at":"2020-10-14 12:00:00"}]';
my $regex = qr/{[^}]*"updated_at":"(?!2020-10-12)[^"]*"}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}