import Foundation
let pattern = #"{[^}]*"updated_at":"(?!2020-10-12)[^"]*"}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[{"id":"1","status":"0","created_at":"2020-10-12 12:00:00","updated_at":"2020-10-12 12:00:00"},{"id":"2","status":"1","created_at":"2020-10-13 12:00:00","updated_at":"2020-10-13 12:00:00"},
{"id":"3","status":"2","created_at":"2020-10-14 12:00:00","updated_at":"2020-10-14 12:00:00"}]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)