using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(['""`]).*?\1";
string input = @"Split on spaces, except ""for this"", and 'this section', and `ignore this too`.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}