# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"gateway=((\d{1,3}(\.\d{1,3}){3},)*172.17.2.1(,\d{1,3}(\.\d{1,3}){3})*) "
test_str = (" 0 A S dst-address=0.0.0.0/0 gateway=172.29.150.17,172.29.150.25 gateway-status=172.29.150.17 reachable via gre-tunnel1,172.29.150.25 reachable via gre-tunnel2 distance=10 scope=30 target-scope=10 routing-mark=INET-SERVERS \n"
" 1 A S dst-address=0.0.0.0/0 gateway=172.17.2.1 gateway-status=172.17.2.1 reachable via bridge-outside1 distance=1 scope=30 target-scope=10 routing-mark=to-outside1 \n"
" 2 A S dst-address=0.0.0.0/0 gateway=172.17.3.1 gateway-status=172.17.3.1 reachable via bridge-outside2 distance=1 scope=30 target-scope=10 routing-mark=to-outside2 \n"
" 3 A S dst-address=0.0.0.0/0 gateway=172.17.2.1,172.17.3.129 gateway-status=172.17.2.1 reachable via bridge-outside1,172.17.3.129 unreachable distance=1 scope=30 target-scope=10 \n"
" 4 A S dst-address=10.0.0.0/8 pref-src=10.150.25.253 gateway=172.29.150.17,172.29.150.25 gateway-status=172.29.150.17 reachable via gre-tunnel1,172.29.150.25 reachable via gre-tunnel2 distance=10 scope=30 target-scope=10 \n"
" 5 ADC dst-address=10.150.25.0/24 pref-src=10.150.25.253 gateway=bridge-mgmt-inside gateway-status=bridge-mgmt-inside reachable distance=0 scope=10 \n"
" 6 ADC dst-address=10.150.26.0/24 pref-src=10.150.26.253 gateway=bridge-wireless-tensor-dev gateway-status=bridge-wireless-tensor-dev reachable distance=0 scope=10 \n"
" 7 ADC dst-address=10.150.27.0/24 pref-src=10.150.27.253 gateway=bridge-public gateway-status=bridge-public reachable distance=0 scope=10 \n"
" 8 ADC dst-address=10.150.28.0/23 pref-src=10.150.28.253 gateway=bridge-inside2 gateway-status=bridge-inside2 reachable distance=0 scope=10 \n"
" 9 ADC dst-address=172.17.2.0/25 pref-src=172.17.2.12 gateway=bridge-outside1 gateway-status=bridge-outside1 reachable distance=0 scope=10 \n"
"10 ADC dst-address=172.17.3.0/25 pref-src=172.17.3.12 gateway=bridge-outside2 gateway-status=bridge-outside2 reachable distance=0 scope=10 \n"
"11 ADC dst-address=172.29.150.16/29 pref-src=172.29.150.22 gateway=gre-tunnel1 gateway-status=gre-tunnel1 reachable distance=0 scope=10 \n"
"12 ADC dst-address=172.29.150.24/29 pref-src=172.29.150.30 gateway=gre-tunnel2 gateway-status=gre-tunnel2 reachable distance=0 scope=10 ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.