using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\r\n|^).{1,18}(?=(\r\n|$))";
string input = @"фундаментные
опора подвижная
закладные изделия мн 57 1
изготовление металлоконструкций";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}