using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\bgoogle\.com$)|(?:\bgoogle\.com\.au$)|(\bgoogle\..*)";
string input = @"Should not match:
google.com.au
google.com
Should match:
google.net
google.org
google.com.pk";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}