// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\bgoogle\.com$)|(?:\bgoogle\.com\.au$)|(\bgoogle\..*)").unwrap();
let string = "Should not match:
google.com.au
google.com
Should match:
google.net
google.org
google.com.pk";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}