$re = '/^[-+]?\d+(?:\.\d+)?(?: [-+]?\d+(?:\.\d+)?)*$/m';
$str = '15 35 -45 8 -2.3 4564.18 56
12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);