re = /^[-+]?\d+(?:\.\d+)?(?: [-+]?\d+(?:\.\d+)?)*$/m
str = '15 35 -45 8 -2.3 4564.18 56
12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end