#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<metaData\s+key="([^"]+)">((?!<\/metaData>).+)<\/metaData>"
Local $sString = " <metaDataSet>" & @CRLF & _
" <metaData key="DocName">mm1266505-20180330195251.txt</metaData>" & @CRLF & _
" <metaData key="TARGET">Brazil BES</metaData>" & @CRLF & _
" <metaData key="com.ibm.wmqfte.OriginatingUser">eimb@CORPWEB</metaData>" & @CRLF & _
" <metaData key="com.ibm.wmqfte.OriginatingHost">B051S317.jci.com</metaData>" & @CRLF & _
" <metaData key="com.ibm.wmqfte.TransferId">414d512050445053514d513031202020770fbe5aacf88f20</metaData>" & @CRLF & _
" <metaData key="com.ibm.wmqfte.Priority">0</metaData>" & @CRLF & _
" </metaDataSet>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")