using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^|[^\S\r\n]+|\})\.\D[\w-]+";
string input = @".class {}
@media print {
.class {}
}
#id {
.class {}
}
.class {}.class {} .class {}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}