#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(<((?!<).)*(:\n)((?!<).)*>)*(((?!<).)*)(<\/(((?!<).)*)>)*"
Local $sString = " <p class=3DMsoNormal style=3D'mso-layout-grid-align:none'><span style=3D'font-size:" & @CRLF & _
"8.0pt'>$</span><span lang=3DEN-US style=3D'font-size:8.0pt;mso-ansi-language:" & @CRLF & _
" EN-US'>ogrnNomer</span><span style=3D'font-size:8.0pt'>$</span><span" & @CRLF & _
" style=3D'font-size:8.0pt;background:yellow;mso-highlight:yellow;mso-fareast-language:" & @CRLF & _
" RU'><o:p></o:p></span></p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")