# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\S)(\d+(?:,\d+)?)\s*(?:(?:in(?:ch)?|\")(?:\s+W)?)?\s?(?:x|by)\s?(\d+(?:,\d+)?)(?:\s?x\s?\d+(?:,\d+)?)*\s*(?:(?:in(?:ch)?|\")(?:\s+L)?)?(?:\s?x\s?(\d+(?:,\d+)?))*\s*(?:(?:in(?:ch)?|\")(?:\s+H)?)?"
test_str = ("53 inch x 45 inch\n\n"
"10 in by 5 in\n\n"
"53\" W x 74\" L x 15\" H\n\n"
"53 inch W x 74 inch L x 15 inch H")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.