const regex = /^([0-3]($|\.)|4.(0|[0-9]($|\.))|4\.10\.190[0-3])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-3]($|\\.)|4.(0|[0-9]($|\\.))|4\\.10\\.190[0-3])', 'gm')
const str = `4.10.19041401
4.10.190
4.9
4.0.
4.9.
3
3.
30
^([0-3]|4.(0|([0-9]\\.))|4\\.10\\.190[0-3])
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}