$re = '/(*UCP)-P(.*) -N([\p{Lu}- ]+)(?=[\p{Lu} ]) ([\p{L}- ]*?) ?(\d{2}\.\d{2}\.\d{4})? ?N°Dossier (.+)/m';
$str = '-PC:\\Chemin Fichiers\\ -NLE-KING JUNIOR Pierre Jean-Marc 31.07.1967 N°Dossier XYZ:1
-PC:\\Chemin Fichiers\\ -NLE-KING JUNIOR 31.07.1967 N°Dossier XYZ:1
-PC:\\Chemin Fichiers\\ -NLE-KING JUNIOR Pierre Jean-Marc N°Dossier XYZ:1
-PC:\\Chemin Fichiers\\ -NLE-KING JUNIOR N°Dossier XYZ:1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);