package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[^À-ú]|^)\b(MyString)\b(?:[^À-ú]|$)`)
var str = `MyString
Lorem ipsum. MyString dolor sit amet
(MyString)
MyString
BetweenCharactersMyStringIsNotFound
éMyStringé
ùMyString
MyStringÖ
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}