re = /^(?:[A-Za-z0-9]{17}|[A-Za-z0-9]{8}[*_][A-Za-z0-9]{2})$/m
str = '5UXWX7C56BA12345
False False
5UXWX7C56BA123456
True True
5UXWX7C56BA1234569
True False UNEXPECTED
5UXWX7C5*B
False False
5UXWX7C5*BA
True True
5UXWX7C5*BA1
False False
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end