# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)(2\[(.+?)\])(.*)/$2 /g;t' <<< "0[0]1[100]2[fellow_starmadian]"