#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.*)(2\[(.+?)\])(.*)"
Local $sString = "0[0]1[100]2[fellow_starmadian]"
Local $sSubst = "$2 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)