package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*)(2\[(.+?)\])(.*)`)
var str = `0[0]1[100]2[fellow_starmadian]`
var substitution = "$2 "
fmt.Println(re.ReplaceAllString(str, substitution))
}