re = /(.*)(2\[(.+?)\])(.*)/
str = '0[0]1[100]2[fellow_starmadian]'
subst = '$2 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result