const regex = /^(?:(?<caml>\w+(?:\-\w+)+)|\[(?<with>[a-z\d-]+)(?<qualify>.+)\]|\[{1,2}\.{3}(?<all>[\w\-]+)\]{1,2}|\((?<group>[\w\-]+)\)|(?<reserved>[@_][\w\-]+)|(?<same>\.)|(?:(?<subpath>(?:(?:[\/\\][^\/\\]+)+[\/\\])|[\/\\])(?<nested>[^\\\/]+)))$/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?<caml>\\w+(?:\\-\\w+)+)|\\[(?<with>[a-z\\d-]+)(?<qualify>.+)\\]|\\[{1,2}\\.{3}(?<all>[\\w\\-]+)\\]{1,2}|\\((?<group>[\\w\\-]+)\\)|(?<reserved>[@_][\\w\\-]+)|(?<same>\\.)|(?:(?<subpath>(?:(?:[\\\/\\\\][^\\\/\\\\]+)+[\\\/\\\\])|[\\\/\\\\])(?<nested>[^\\\\\\\/]+)))$', 'm')
const str = `this_is-hyphened`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}