$re = '/(?i)(?<!RT )(?<!RT)@(\w+)/m';
$str = 'RT @u1, @u2, u3, @u4, rt @u5:, @u3.@u1^, rt@u3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);