$re = '/^[a-z]+[a-z0-9._-]+[a-z]+@+[a-z0-9]+[._-]?+[a-z0-9]+(?:[._-][a-z0-9]{2,})+$/m';
$str = 'abc@abc-abc
abc@abc-abc.abc
abc@abc-abc.abc.abc
abc@abc-abc.abc-abc.abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);